Difference between revisions of "Building with Cmake FAQ"

From Sim-Im
Jump to: navigation, search
(Q: How to build Sim-IM without KDE support?)
(Q: How to build Sim-IM without KDE support?)
Line 2: Line 2:
 
=== Q: How to build Sim-IM without KDE support? ===
 
=== Q: How to build Sim-IM without KDE support? ===
  
'''A:''' For Sim-IM 0.9.4* and for old revisions of Sim-IM 0.9.5 you should use  
+
'''A:''' For Sim-IM 0.9.4.* and for old revisions of Sim-IM 0.9.5 you should use  
  
 
  cmake -D USE_KDE3:boolean=false
 
  cmake -D USE_KDE3:boolean=false

Revision as of 18:37, 17 January 2008

Linux

Q: How to build Sim-IM without KDE support?

A: For Sim-IM 0.9.4.* and for old revisions of Sim-IM 0.9.5 you should use

cmake -D USE_KDE3:boolean=false

and for Sim-IM 0.9.5 rev. 2106 or newer

cmake -D ENABLE_KDE3:boolean=false

Q: How to build Sim-IM with debug info?

A: cmake -D CMAKE_BUILD_TYPE=Debug